Alimentação do arduino pro mini


#1

Boa tarde. Gostaria que me ajudassem com um grande problema.
Estou desenvolvendo um projeto para trabalhar no carro ou moto, ligado direto na bateria.
O projeto está montado e testado, funciona perfeitamente no pc, mas quando tento ligar em outra fonte, simplesmente não funciona.
Já tentei de tudo, regulador de voltagem, divisor de tensão, step down e até ligar direto na bateria através do pino raw.
Não sei mais o que fazer.
Se alguém puder me ajudar agradeço muito.
Minha placa é arduino pro mini para 5v.
Segue foto da minha placa.

Obrigado.


#2

Se voce ligou direto na bateria provavelmente voce ja queimou esse arduino, se ainda nao estiver queimado, ja fiz uma ligação destas usando stepdown, é so ligar direto no vcc de alimentação do arduino, esse ao lado do A3, que vai embora.


#3

Boa tarde Michels. Já fiz isso e nada amigo.
Ainda não queimou.
Tá difícil.


#4

acho que nesse caso voce poderia partir pra ‘verificar a corrente’, tanto a corrente total do circuito que vc usa, quanto se circula corrente quando vc conecta o arduino na bateria, talvez esta bateria em questao tenha um circuito de proteção interno que impede ela de ligar com ‘baixa corrente’.
Parece ridiculo mas ja vi acontecer kk


#5

Imagino que seja esse o caso, já que voltagem tem até de sobra.
Vou ver isso.
Valeu por enquanto.


#6

Meu caro. Me permita dar um pitaco no seu projeto. Tenho experiência com essas placas mini e enquanto estava energizando a bichinha com 12 V deu pau todas as vezes. A que mais suportou foi a BlackBoard da Robocore. Adotei uma solução não convencional. Coloquei um diodo Zener invertido no polo positivo e, com a carga, a tensão cai para 9V. Depois que fiz isso tenho placas funcionando há meses sem nenhum problema.


#7

Oi Boemer.
Obrigado pela opinião, vou tentar, mas o meu problema é que não consigo fazer o projeto funcionar em outra fonte a não ser no pc, seja qual for a voltagem.
O arduino liga mas não liga o resto, que são dois reles e dois leds. Acho que é problema de amperagem, sei lá.


#8

Você está um modulo relê? Se for, acho que deve mudar a alimentação. Se quiser te passo o que fiz e deu bem certo, inclusive reduzindo problemas com EMI


#9

estou usando um módulo com dois reles.
Se puder me passar o que fez pode ser que me dê uma luz porque tá difícil.
Quanto a alimentação, cara, já fiz de tudo, divisor de tensão, regulador de voltagem 7805, pilha 2032 com 6v, step down regulado em 5v e a bateria ligada direto no pino raw.
Nada funciona, só no pc mesmo. Parece que não tem carga suficiente para alimentar todo o circuito. Mas como que no pc vai, que é de 5v e só fornece 500mA?
Mistério!
Detalhe, estou usando conversor usb/ttl para o pc. Tentei até usá-lo depois do step down ligado à bateria e nada.


#10

Sua placa não deve suportar mais do que 100mA. Se a carga for superior a isso trava tudo mesmo.
Vou te passar o que fiz e deu certo.
O modulo tem um jumper entre o VCC e JD-VCC. Retire o jumper
Conecte esse VCC no 5V do Arduino mas NÃO conecte o GND no GND do Arduino
Conecte um fonte externa de 5V no JD-VCC e o GND no GND da placa.
A fonte externa pode ser o step down alimentado pelos 12V que está indo para o Arduino
Outra coisa que deve observar são os LEDs que está usando. Alguns consomem até 30mA. Talvez retirar os LEDs e testar sem eles pode te dar uma boa indicação.
Espero que te ajude


#11

Blza.
Vou testar aqui e te digo.


#12

Fala Boemer. Blza?
Cara, tentei aqui o que vc falou mas não deu também. E ainda fritou o step down.
A minha dúvida é: Por que funciona perfeitamente no usb do pc mas não com outra fonte?
Deveria funcionar normalmente.


#13

Fritou o step down?? Não h’razão para isso. O que te passei é o que uso e funciona. Vou verificar para ver se não escrevi nada errado.


#14

Talvez eu tenha ligado algo errado. Sei lá.


#15

Passei a informação correta. Talvez não tenha explicado direito quanto ao VCC.
Não usa o VCC nem o GND que está junto aos pinos de sinal. Usa somente os pinos onde estava o jumper. Os pinos de sinal são os mesmos.
JD-VCC na fonte externa e o VCC ao lado dele no pino 5V da placa e ground no gound da placa não no grround do Arduino.
Mas de qualquer forma se não energizou o Arduino volto ao que disse antes. Essas plaquinhas não suportam 12V. Faça uma leitura do pino VCC 5V da placa. Se der 5V não sei mais o que dizer. Se der 0V o mais provável é que queimou o CI de regulagem de tensão.
Quando você liga no PC, a alimentação é feita pelo pino 5V do FTDI sem passar pelo regulador de tensão. Quando liga na fonte externa a alimentação passa pelo CI regulador de tensão e ajusta para 5V.
Se o regulador estiver queimado vai dar 12V no pino de alimentação mas a tensão é interrompida no CI.
Nesse caso a solução é trocar o CI SMD regulador de tensão, o que é uma operação delicada. O CI custa menos de 2 Reais, mas só deve achar na internet
Uso o CI RFL 117-5 que é bem robusto e não queima fácil.
Ou então trocar a placa que, depois de queimar algumas, comprei a BlackBoard PRO mini da Robocore, reduzi a alimentação para 9V e passei a ser feliz de novo (rsss).
Acho que é isso, porque já tive o mesmo problema e resolvi dessa forma
Agora só posso desejar boa sorte.


#16

De qualquer forma obrigado Boemer.
Já fiz tudo isso e nada. Só queimou mesmo o step down com essa ligação.
O circuito todo ligado novamente no pc funciona que é uma beleza.
Esqueci de dizer, também uso um módulo bluetooth no circuito.
até acende tudo, mas os relés ficam estalando sem parar e o bluetooth pareia mas logo despareia novamente sozinho.
Não da pra entender.


#17

Se ligou na sequência que te falei não tem como queimar o step down. Não tem nenhuma sobrecarga. Só foi ligado o positivo no JD_VCC . Se fosse uma ligação errada queimaria o modulo relê, não acha? O step down queimou não foi por isso.

Para o relê parar de disparar sozinho tenta isso:
No SETUP
digitalWrite(Relay_1,HIGH); // comanda o relê 1 para 1
digitalWrite(Relay_2, HIGH); // comanda o relê 2 para 1
pinMode(Relay_1, OUTPUT); // define o pino de saída como OUTPUT
pinMode(Relay_2, OUTPUT);// define o pino de saída como OUTPUT

Exatamente nessa ordem
O resto teria que ver o circuito.Sem isso não dá para ter certeza de nada


#18

O programa está certo, pois funciona normalmente, como disse, no usb.
O problema é a alimentação que não achei o porque de não funcionar fora do usb.
Deveria funcionar normalmente com qualquer outra fonte de 5v ligada na mesma entrada que uso no usb, não concorda?


#19

Confere o aterramento.


#21

Olá pessoal. Obrigado pela ajuda e interesse.
Consegui resolver meu problema usando carregador de celular automotivo.
Funcionou perfeitamente.
Não sei porque só com ele e com os outros redutores e reguladores não.

Abraço;)