Alimentação externa da ESP8266 não funciona


#1

Estou utilizando uma ESP8266 com a interface do Arduino e tendo um problema quanto a alimentação.

Quando eu ligo a placa pela USB (seja pelo computador ou fonte) funciona perfeitamente mas quando alimento a placa pela Vin o boot só acontece se eu pressionar RESET.

Vi muitos relatos desse problema na internet mas não encontrei uma solução, mas tem um detalhe, não são todas ESP8266 que apresentam esse problema, eu tenho uma da Lolim que funciona perfeitamente a que tem esse bug é a KitDev da Doit.

Alguem já passou por isso, encontrou algo para contornar?


#2

Não conheço essa placa, mas em muitos circuitos, dependendo da forma pela qual a fonte de alimentação liga, o circuito trava. E em muitos casos é possivel implementar um reset automático durante a ligação usando um capacitor e um resistor para gerar uma constante de tempo que simula o pressionar do botão de reset.


#3

Source https://www.sigmdel.ca/michel/ha/esp8266/doit_nodemcu_v3_en.html#power

Fortunately, preliminary tests show that the ESP start correctly when power is applied via the 5V VIN pin contrary to a review found on the Banggood site. Perhaps that problem was limited to the ESP12E development kit or, more likely, the problem was linked to the the power supply used by that reviewer. I have done better testing and I can confirm that I get this problem with 3 different power supplies. I need to manually press the reset button after applying power to get the board to boot correctly. Surprisingly, the ESP8266 boots properly when these same power supplies are connected through the micro-USB port.

Bom, agora sei que não estou sozinho na pior das hipoteses vou ter que implementar sua sugestão ou alimentar pela USB mesmo :-/