Computador não envia sketch para arduino


#1

Olá!
Estou afastado do arduino e estou tentando retomar o pouco que sei porem a comunicação do computador com a placa não funciona apresenta a seguinte mensagem “SERIAL port COM 1 not found”, como encontrar esta porta , utilizando a opção tools do IDE a opção para selecional a porte não esta ativa
O cabo do arduino é conectado na entrada USB , esta é com1?
Poderia o cabo estar com problema, masao conectar aplaca o led acende, estou utilizando a placa da robocore.

César


#2

@cesarrs Não seria apenas o caso de configurar a IDE para a porta correta que o Arduino está apontando?

Repare que na imagem acima, o rodapé informa que o Arduino está conectado à porta COM12, portanto, nas configurações, o usuário marca COM12 também.

Se isso, não funcionar, tente o seguinte:

apresenta a seguinte mensagem “SERIAL port COM 1 not found”

O Arduino está tentando conectar na porta COM1, mas ou ela está sendo usada por outro aparelho/processo ou ela está indisponível ou com outro número.

O cabo do arduino é conectado na entrada USB , esta é COM1?

Não, USB é USB, o que o Arduino faz é converter de USB para Serial (COM), mesmo em MCU’s que já tem porta USB.

Tente o seguinte, levando em conta que está usando Windows.

  1. Vá no “Painel de Controle” e pesquise por “Gerenciador de Dispositivos” e execute-o.
  2. Na lista procure por “Portas (COM e LPT)” e clique com o botão direito em “Portas de Comunicação(COMX)” e selecione “Propriedades”.
  3. Em “Configurações de Porta” pressione o botão “Avançado”.
  4. Em “Número da Porta COM” informe o número 1.

#3

Sandro!
Obrigado pelo interesse, porem a opção de selecionar a porta não esta
habilitada no arduino, não consigo selecionar, utilizando a opção que voce
apresentou de utilizar o gerenciador , segue a tela que o gerenciador
apresenta.


#4

O teu Arduino é original? Se não, pode ser que precise de drivers FTDI, se o chip FTDI for clone chinês, pode precisar de drivers mais específicos.

Mas antes de partir para instalação de drivers, tenta fazer esses procedimentos.


#5

Comprei da Robocore, estava funcionando , parei por uns meses e retomei o
assunto agora e não consigo, o interessante é que o led da placa liga, e
tento transferir o programa Blink para testar e nada, mas ao final do dia
vou tentar os procedimentos dos drives.

Obrigado.

César


#6

Se você comprou na RoboCore e é este o produto:

Então é original e o problema não é com drivers, pois estes modelos não usam mais chip FTDI e sim um MCU mais simples para fazer a conversão USB -> Serial.


#7

A placa é da Robocore mesmo, a preta, os componetes diferem um pouco, mas o
que não entendo é que a dois meses atars estava funcionando, meu setor é a
mecanica, pergunto um “tombo” pode er danificado a placa, é sensivel?

César


#8

Sandro!
Pensando um pouco, o problema não é na USB pois o mouse funciona, o
problema n~so é no cabo pois o led da placa liga, então pode sim ser
problema na placa?

Aplaca é a blackboard do Robocore, agora fiquei preocupado quer dizer que
existem placas piratas aonde a qualidade compromete o trabalho?
Aonde comprar placas confiaveis?

César


#9

Olá @cesarrs a sua placa é um clone do Arduino fabricado pela Robocore chamado Blackboard e ele usa um chip FTDI para fazer a conversão USB para Serial.

Então, há uma mensagem na página do produto:

Tente reinstalar o driver, caso a sua placa não funcione, a Robocore tem obrigação de te dar suporte, inclusive eles tem um fórum onde você pode obter um melhor suporte para os produtos vendidos por eles.


#10

Sandro!
Resolvido , você esta certo faltava o drive, estava pensando em comprar
outra placa, mas felizmente voce resolveu.
Obrigado

César