Medir potência em sistema trifásico para multimedidor


#1

Senhores. Estou tentando fazer um medidor trifásico com o Arduíno. Mas me veio uma dúvida e quero compartilhar.
A maioria dos medidores que já ví feitos com Arduíno são monofásicos, basicamente pega a corrente medida no sensor e multiplica-se pela tensão da fase em que o sensor de corrente esta ligado. No entanto no sistema trifásico acho que não dá para fazer isso, pois alguns aparelhos são ligados em 127 e outros em 220. E ate onde eu sei não dá para saber quando a corrente está fluindo sob uma tensão de 127V ou 220v.
Imagine que estamos medindo as potencias de 2 fases. Esta fase está Alimentando 2 aparelhos um consome 1.000w em 220v e o outro consome 1.000w em 127v. Calculando individualmente a corrente dos aparelhos teríamos.
Aparelho 1: 1000÷220=4.54A
Aparelho 2: 1000÷127=7.87A
Neste caso vamos ter uma corrente dividida nos cabos dessa forma.
Fase 1: 4.54A
Fase 2: 4.54A + 7.87A= 12.41A
Tendo as correntes em cada fase vamos “fazer de conta” que estamos com os sensores de correntes ligados no quadro geral medindo estas correntes totais em cada cabo e pegando a referencia de Tensão de cada fase com o neutro ou seja 127v
Assim na fase 1 teriamos. 4.54A x 127v= 576.58w
Na fase 2
12.41A x 127v=1.576,07w

Potencia total=2.152,65w

Conclusão
A potência correta total no circuito e de 2.000w no entanto quando nos referenciamos apenas a tensão de cada fase erramos para cima 152,65w(7,6% de erro)
Isso me deixou em dúvida até se os medidores comercias medem corretamente.
Alguém saberia fazer o circuito de forma que isso não aconteça?
Obrigado. Espero que tenha sido claro. Se não favor postarem suas dúvidas e espero que eu esteja errado e a solução seja mais simples do que penso.


#2

Dá sim. Quando as cargas não estão balanceadas deve-se utilizar outro método para medição, com dois wattímetros ou três. Medidores trifásicos já possuem essa função.
O erro está em somar as correntes, você somou uma corrente com um angulo de 0º com uma corrente com angulo de 120º, o valor 12,41A não será mostrado pelo sensor de corrente.
Acho que é esse o erro, me corrija se estiver errado.


#3

Sim o erro ocorre exatamente aí nas diferenças do angulo de fase. Estou pesquisando um pouco sobre estas medição mas estou encontrando muita informação sobre sistemas equilibrados. para não equilibrados quando encontro são explicações complexas sem nenhuma explicação pratica.