Problemas com cnc Shield e arduino


#1

Boa Tarde !!!
Sou novo aqui pessoal, não sou conhecedor da parte Eletrônica, e estou com problemas
na cnc caseira que estou fazendo, parte mecânica está pronta porém a parte Eletrônica
não consegui acertar, estou utilizando arduino uno + cnc Shield com drivers A4988 e motores
de passo nema 17.
O eixo X funciona normal, Eixo Y motor gira apenas para um dos lados, e o eixo Z nem liga.
ja troquei os drivers do eixo Z e Y para o eixo X, e funcionaram normalmente. ou seja os motores
estão funcionando corretamente e os drivers tbm, eu pensei que era problema na cnc shield
e então eu comprei outra, e continuou com o mesmo problema.
alguém ja passou por isso ? sabe me dizer oq pode ser ?
desde já obrigado …


#2

Estamos com o mesmo problema. Recentemente terminei de montar a minha CNC, montei a parte eletrônica, mas estou me deparando com um problema que não consigo resolver, já tentei todas as formas que estiveram ao meu alcance. Tenho uma placa Arduino UNO, uma CNC Shield, os Drivers DRV 8825 e os motores de passo Nema 23 km C051-07v, tudo estava configurado, liguei os motores funcionaram por um tempo mas pararam em seguida, pensei comigo mesmo, agora lascou tudo…mas depois percebi que as placas CNC Shield possui um fusível, não sei o que aconteceu ele queimou, soldei um pedacinho de fio e tudo voltou a funcionar, mais depois percebi que os motores dos eixos X e Y só giravam em um único sentido, apenas o o motor do eixo Z atende aos comando girando em ambas as direções (Z+) e (Z-) já testei os drivers DRV 8825, em uma impressora 3D que possuo funcionaram perfeitamente, já troquei os drivers DRV 8825 por A4988 e não tem jeito, já calculei e recalculei a amperagem dos motores com a fórmula seguinte: V(ref) I*(5Rs) onde (I) é a corrente máxima do motor, (5) é uma constante para o DRV 8825 e 8 para o A4988 e (Rs) é o valor em Ohm dos resistores que ficam do lado do trimpot do driver DRV 8825, no caso 100r que equivale a 0.1 Oms, Então fica assim: V(ref) 2(5*0.1) =1, não sei mais o que fazer, as placas CNC Shield não têm mais o que queimar, pois não possui muitos componentes, só resta a placa Arduino UNO, que não troquei, pois só possuo ela e outra arduino mega que está na impressora 3D, Se alguém poderia me orientar em que fazer para resolver isto, agradeceria bastante. Na minha opinião, acho que o problema está na placa Arduino UNO, já compre uma shield e mais uma arduino UNO para fazer os teste, estou esperando


#3

@RichardFalcos conseguiu resolver este problema da cnc shield? Estou com um problema idêntico…


#4

Olá galera! Depois de 2 dias quebrando a cabeça e tentando resolver, eu cheguei na solução do meu problema que parecia muito com os problemas de vocês, eixo andando pra um lado ou eixo espelhado!
O problemas estava no GRBL , eu estava upando errado ele pro Arduino, fiz exatamente a instalação como no vídeo nesse vídeo, meu problema era na estava hora de instalar a biblioteca na IDE Arduino! A partir do tempo 4:20, desse vídeo https://youtu.be/31R_Bgd5L_k


#5

Problema resolvido, troquei a placa Arduino Uno e funcionou perfeitamente…


#6

Galera, estou com um problema que esta me deixando meio frustrado, montei uma cnc caseira com base em uns projetos q encontrei na internet estou usando cnc shield v3 com drives a4988 e arduino uno para controlar motores nema 17 2,2 kg, usei o o grbl e o universal g code sender para fazer o controle, o problema é que o eixo z funciona normalmente porem o x e y n, só tremem , a ligação das bobinas estão corretas, a Vref tbm , troquei os motores e os drives de lugar o que me levou a constatar que o problema n se encontra nos drives nem nos motores, gostaria de saber se alguem sabe como resolver isso…


#7

Olá
sou novo no fórum, ainda estou comprando peças pra minha cnc.
Espero ajudar com o que achar correto para a montagem cnc arduino.
Nesse caso dos motores vejam o vídeo.


até