Erro na carga de programa no arduino Nano

Senhores…não se pra vocês, mas para mim esse tal de arduino é bronca em cima de bronca. Desenvolvi um programinha besta para utilizar numa plataforma Nano xing-ling. O danado compila mas na hora da carga acontecem duas coisas:

1 - demora pra caramba…aí você ja pensa “tem algo errado”
2 - mostra a seguinte mensagem de erro:

Ocorreu um erro enquanto o sketch era carregado
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xd1
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xd1
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xd1
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xd1
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xd1

E continua até o “10 do 10”.

Pensei que fosse problema no cabo, comprei outro mas não funcionou. Já usei 3 Nanos e o problema persiste. Alguém já passou por isso? Alguma sugestão? Please.

Tem 2 bootloaders para o Nano. Veja se está utilizando o novo e troque para o anterior, ou vice-versa, no menu de escolha da placa.

Pois é…e não é que o troço funcionou? Muito obrigado pela informação.

1 Curtida

Tava na cara né!? Você é que é “bronco” não o Arduino. Da próxima vez, seja mais humilde e admita que você é que é o enrolado!

Calma companheiro…depois que a gente acha o problema fica muito fácil. Mas como que eu ia saber que o nano possui 2 programas?

Mas já que você tocou no assunto, essa IDE não é coisa boa não. Você monta o programa, tudo direitinho, programa bobo. E aí do nada a danada da IDE ao compilar começa a mostrar uns erros sem pé e sem cabeça. Aí você mexe numa porcaria qualquer e de repente fica bom…coisa de doido.