Web client com o esp8266 no modo station e acess point

Olá pessoal.

Estou desenvolvendo um projeto onde o ESP8266 se conecta a outro ESP8266 e os dois necessitam estar em modo WIFI_AP_STA. Porém quando eu o coloco nessa configuração o esp que esta como client não envia os dados para o outro esp.

Imagine a situação, (> = conectado):

 celular > esp > servidor; Dessa maneira funciona tudo ok;

 esp > esp > servidor; Dessa maneira o esp não consegue enviar as informações.

Nota: Todos os dois ESP’s precisam ficar em modo Acess Point e Station.

Isso está me tomando muito tempo e não consigo encontrar nenhuma maneira de resolver, somente os mesmos tutoriais de como ligar o WiFi do ESP em modo acess point kkkkk.

No momento estou usando o protocolo TCP, porém já tentei com o protocolo UDP, HTTP e aconteceu o mesmo problema.

Espero que alguém possa me ajudar.

Obrigado :slight_smile:

Bom dia !
Só um Esp pode ficar em modo Acess Point.
Os dois neste modo não funcionam .
Uso o protocolo UDP e funciona os dois normalmente .

1 Curtida

Com certeza. Assim funciona comigo também. O problema é que todos eles precisam estar nos dois modos. Pois outros esp’s podem se conectar nesse ultimo, criando uma “rede” com os esp’s.

Provalmente você já usava esse ESP, compila novamento seu projeto só que agora marque para limpar todos os dados da flash, dados de configuração de acesso Wifi podem estar atrapalhando.

Vou tentar fazer isso. Muito obrigado. Eu volto pra avisar se funcuonou pra mim ou não.